Начальная страница

×

  • Начальная страница
  • Следующая
EasyScheduler 1.10
Руководство по эксплуатации
EasyScheduler – это визуальное средство управления запуском консольных приложений на удалённых серверах.
Позволяет планировать запуск задач с возможностью указать временные промежутки, отслеживать
ход выполнения задач, вести историю запуска задач, автоматически загружать файлы на удаленные сервера.
EasyPortal © 2016-2022 компания EasyData


Общая информация и архитектура решения

EasyScheduler - это планировщик задач, позволяющий управлять запуском консольных приложений на удалённых серверах. Позволяет планировать запуск задач с возможностью указывать временные промежутки, отслеживать ход выполнения задач, вести историю запуска задач, автоматически загружать файлы на удалённые сервера. Для удалённого запуска задач используется утилита EasyRuntime, обеспечивающая доступ к серверу, на котором должны запускаться задачи.
Управление рантайм сервером
EasyScheduler управляет рантайм сервером через лаунчер, который входит в состав EasyRuntime. С его помощью осуществляются такие операции, как запуск и остановка рантайм сервера, а также загрузка новой версии EasyRuntime.
Проекты
Через проекты осуществляется контроль доступа к задачам и пакетам непосредственно для каждого пользователя. Для разграничения прав доступа используются группы, пользователь может принадлежать только к одной группе (отсутствует, писатель, читатель, оператор).
Задачи
Запуск задач осуществляется асинхронно, по завершению выполняемой задачи EasyRuntime отсылает отчет в EasyScheduler. EasyRuntime контролирует повторный запуск задач – нельзя запустить задачу, которая уже выполняется. EasyScheduler проверяет для задачи версию локального пакета и обновляет пакет на сервере, если в планировщик была загружена новая версия пакета.
Пакеты
Пакет представляет собой архив в формате zip, tar, tar.gz или 7z с файлами программы, которую необходимо запустить на удалённом сервере.
Пакеты поддерживают версионность: при наличии новой версии пакета рантайм сервер автоматически загрузит новый файл пакета. EasyScheduler поддерживает два типа пакетов: простой пакет (любой архив) и talend пакет.
Онлайн справка создана с помощью Dr.Explain


Быстрый старт

Как быстро запустить задачу в EasyScheduler.
Пример: нужно запустить задачу по проверке версии Java на неком удалённом сервере.
Для этого нужно:
1. На требуемом сервере должна быть установлена утилита EasyRuntime
2. В EasyScheduler cоздать сервер
2. Создать проект (если проект уже создан, убедитесь, что назначены права доступа).
3. Создать задачу, связать её с проектом и сервером. В строке выполнения прописать консольную команду java -version:
5. Запустить задачу:
5.1. Задачу можно запустить вручную, выделив её в списке и нажав кнопку "Запустить" в верхней панели управления:
5.1. Или, если задачу нужно запускать по расписанию, то можно создать триггер


Интерфейс программы

Система
Рантайм сервера
Группы рантайм серверов
Проекты
Пакеты
Задачи
Правила
Триггера
История
Параметры
Java
Мониторинг
Выполнение задач
История задач
Ресурсы серверов
Профиль пользователя

Содержание Интерфейс программы

Система
Мониторинг
Профиль пользователя


Система

Раздел "Система" содержит в себе основной функционал EasyScheduler:
  • •
    Рантайм сервера - раздел, содержащий список серверов, на которых осуществляется запуск задач. Управление рантайм серверами: запуск и остановка, загрузка новой версии. Сервер имеет признак активности: если сервер неактивен, задачи на нем запускаться не будут.
  • •
    Группы рантайм серверов - раздел, в котором можно объединять несколько рантайм серверов в группы. Это делается для балансировки нагрузок и обеспечения отказоустойчивости. Для запуска новой задачи выбирается сервер с наименьшим количеством задач внутри группы.
  • •
    Проекты - раздел, содержащий список проектов. Назначение прав доступа к проектам для пользователей, управление рассылкой уведомлений.
  • •
    Пакеты - раздел, содержащий список пакетов. Каждый пакет содержит свой список файлов, одновременно может быть активен только один файл.
  • •
    Задачи - раздел, содержащий список задач. Управление задачами, настройка правил, управление триггерами, просмотр истории задач. Для пакетов типа Talend поддерживаются дополнительные разделы: "Параметры" (по умолчанию берутся из настроек пакета) и "Java" (настройки запуска Java приложения)

Содержание Система

Рантайм сервера
Группы рантайм серверов
Проекты
Пакеты
Задачи


Рантайм сервера

Раздел "Рантайм сервера" содержит список серверов, на которых осуществляется удалённый запуск задач. Для взаимодействия рантайм сервера и шедулера на сервер устанавливается утилита EasyRuntime.
Верхняя панель управления содержит следующий функционал:
Редактор:
  • •
    Обновить - обновление данных грида;
  • •
    Добавить - добавление нового рантайм сервера;
  • •
    Изменить - редактирование рантайм сервера;
  • •
    Удалить - удаление рантайм сервера.
    Активность:
  • •
    Сделать активным - изменение статуса сервера на активный;
  • •
    Сделать неактивным - изменение статуса сервера на неактивный.
    Активность используется для запрета/разрешения запуска задач на сервере. Задачи запускаются только на активном сервере.
Рантайм сервер:
  • •
    Запустить - запуск рантайм сервера;
  • •
    Остановить - остановка рантайм сервера;
Для редактирования, удаления, изменения активности рантайм сервера необходимо выделить его в списке серверов, после чего станут активными соответствующие кнопки. Для массового удаления или изменения активности выделите необходимые сервера, после чего станут активными соответствующие кнопки.
Внимание! Нельзя удалить рантайм сервер, если к нему привязана задача. Прежде чем удалить сервер, необходимо удалить все привязанные к нему задачи.
Таблица списка рантайм серверов содержит в себе следующие данные:
  • •
    Активность - флаг активности сервера;
  • •
    Название - название сервера;
  • •
    Хост - адрес хоста и порт;
  • •
    Диск - информация об использовании места на жестком диске, где установлен EasyRuntime;
  • •
    Java - версия Java, под которой был запущен EasyRuntime;
  • •
    OS - название операционной системы;
  • •
    Статус - статус рантайм сервера (зеленый флажок - запущен, красный флажок - остановлен, серый флажок - неактивен).
Если строка рантайм сервера выделена красным цветом - на сервере не найдена запущенная утилита EasyRuntime.
Данные о сервере передаются от рантайм сервера, если он недоступен или неактивен, то информация отображаться не будет.
Для быстрого изменения активности сервера используется чекбокс в столбце "Активность". При этом грид не перегружается, оповещение об успешном изменении активности отображается в правой верхней части экрана в виде всплывающей подсказки.
Добавление нового сервера
Для добавления нового сервера необходимо щелкнуть по кнопке "Добавить" в верхней панели, в разделе "Редактор". В открывшемся окне следует ввести данные о сервере:
  • •
    Название – название сервера;
  • •
    Хост – IP адрес или доменное имя сервера, где установлен рантайм сервер;
  • •
    Порт – порт, на котором будет запущен рантайм сервер (по умолчанию 9082);
  • •
    Порт лаунчера - порт, на котором запущен лаунчер (по умолчанию 9100);
  • •
    Активность - признак доступа к рантайм серверу;
  • •
    Кодировка сервера - кодировка, с которой сервер работает по умолчанию. Используется при чтении логов истории задач. Кодировку сервера рекомендуется прописать в случаях, когда используется кодировка, отличная от стандарта, чтобы не прописывать кодировку для каждой задачи отдельно;
  • •
    Параметры рантайм сервера - список параметров рантайм сервера, которым можно присвоить следующие значения:
runtime.path.task-history-log | путь к хранилищу логов истории задач
runtime.path.packages | путь к хранилищу пакетов
runtime.path.temp | путь к временной директории
runtime.rmi.runtime-management-port | сервисный RMI порт
runtime.disk-min-space | необходимое минимальное свободное место (в байтах) на диске, где установлен рантайм, для запуска задач
Изменение параметров вступит в действие после перезагрузки рантайм-сервера;
  • •
    Описание - в этом поле можно оставить небольшой комментарий о сервере (необязательно для заполнения).


Группы рантайм серверов

В данном разделе можно объединять несколько рантайм серверов в группы. Это делается для балансировки нагрузок и обеспечения отказоустойчивости. Для запуска новой задачи выбирается сервер с наименьшим количеством задач внутри группы.
Верхняя панель управления содержит следующий функционал:
  • •
    Обновить - обновление данных грида;
  • •
    Добавить - добавление новой группы рантайм серверов;
  • •
    Редактировать - редактирование данных выделенной группы рантайм серверов;
  • •
    Удалить - удаление выделенной группы рантайм серверов.
Для добавления новой группы серверов нажмите на кнопку "Добавить", в открывшемся окне заполните данные о группе:
  • •
    Название - название группы серверов;
  • •
    Описание - описание группы серверов (необязательно для заполнения).
После нажатия кнопки "Сохранить" группа появится в списке:
Выделив ее, в правой колонке вы увидите список всех рантайм серверов. Добавление в группу осуществляется путем проставления чекбоксов напротив названия необходимых серверов.
Группы серверов можно использовать так же, как и отдельные сервера при настройке запуска задач:
Префикс [G] означает группу серверов.


Проекты

Раздел "Проекты" содержит в себе перечень созданных проектов. Через проекты осуществляется контроль доступа к задачам и пакетам непосредственно для каждого пользователя. Для разграничения прав доступа используются группы, пользователь может принадлежать только к одной группе (отсутствует, писатель, читатель, оператор).
Верхняя панель управления содержит следующий функционал:
  • •
    Обновить - обновление данных грида;
  • •
    Добавить - добавление нового проекта;
  • •
    Редактировать - редактирование проекта;
  • •
    Удалить - удаление проекта.
Для редактирования или удаления проекта необходимо выделить его в списке проектов, после чего станут активными соответствующие кнопки. Для массового удаления выделите необходимые проекты и нажмите кнопку "Удалить".
Внимание! Нельзя удалить проект, если к нему привязаны пакеты или задачи. Прежде чем удалить проект, необходимо удалить все привязанные к нему пакеты и задачи.
Настройка прав доступа к проекту
Для настройки прав доступа к проекту необходимо щелкнуть по его строке в списке проектов, после чего в правой части экрана появится список пользователей:
Для того, чтобы настроить доступ к проекту для определенного пользователя, нужно дважды кликнуть по строке доступа напротив имени этого пользователя. Появится выпадающий список, из которого нужно выбрать группу, к которой будет определен пользователь для данного проекта:
  • •
    Отсутствует - доступ к задачам и проектам полностью закрыт;
  • •
    Писатель - может добавлять, удалять, изменять задачи и проекты, загружать файлы в проект;
  • •
    Читатель - видит все доступные ему задачи и пакеты, но не может редактировать их;
  • •
    Оператор - может запускать задачи, ставить на паузу и снимать с паузы триггера.
После изменения принадлежности пользователя к группе сохранение происходит автоматически, оповещение об успешном изменении прав доступа отображается в правой верхней части экрана в виде всплывающей подсказки.
Для поиска по пользователям начните вводить имя пользователя в строку поиска, подходящие варианты будут подбираться автоматически:
Добавление нового проекта
Для добавления нового проекта необходимо щелкнуть по кнопке "Добавить" в верхней панели. В открывшемся окне нужно заполнить поля:
  • •
    Название - заголовок проекта
  • •
    Описание - в этом поле можно оставить комментарий к проекту (поле необязательно для заполнения)
После нажатия кнопки "Сохранить" новый проект появится в списке проектов:
Настройка рассылки
Подписка на проекты для получения отчета об ошибках и оповещениях по всем задачам, привязанным к тому или иному проекту.
Для того, чтобы внести E-mai в список рассылки на определенный проект, необходимо выбрать нужный проект и перейти в пункт подменю "Рассылка":
Далее нажать кнопку "Добавить" и в открывшемся окне ввести нужный адрес электронной почты:
После нажатия кнопки "Сохранить" адрес появится в списке рассылки на данный проект и данный пользователь будет получать уведомления об ошибках во всех задачах, привязанных к этому проекту.
Чтобы приостановить получение писем, снимите флажок напротив нужного адреса:
Также можно удалить адрес из списка адресов, привязанных к проекту (кнопка "Удалить").
Если используется E-mail зарегистрированного пользователя, то в списке адресов он выделяется зеленым:


Пакеты

Раздел "Пакеты" содержит в себе список пакетов, привязанных к проектам. Пользователь видит только те пакеты, к которым у него есть доступ. Если пакет не привязан к проекту, то он считается общим и к данному пакету получают доступ все проекты.
EasyScheduler поддерживает работу с двумя типами пакетов:
  • •
    Простой пакет - представляет собой архив с файлами, которые необходимо использовать при запуске задач на удалённом сервере. Для подготовки простого пакета к загрузке необходимо запаковать в ZIP архив нужные файлы. EasyScheduler поддерживает загрузку файлов в форматах: zip, tar, tar.gz, 7z
  • •
    Talend пакет - формируется путем экспорта jobs из Talend Studio, который генерирует ZIP файл. Этот файл далее можно загружать в EasyScheduler не производя никаких дополнительных действий для его запуска с передачей параметров контента, описанных для jobs.
Верхняя панель управления содержит следующий функционал:
  • •
    Обновить - обновление данных грида;
  • •
    Добавить - добавление нового пакета (из выпадающего списка можно выбрать простой пакет или Talend пакет);
  • •
    Редактировать - редактирование пакета;
  • •
    Удалить - удаление пакета;
  • •
    Создать задачу - добавление задачи к выбранному проекту и пакету;
Для работы с пакетами и создания задачи необходимо сначала выделить нужный пакет в списке, после чего станут активными соответствующие кнопки.
Внимание! Нельзя удалить пакет, если к нему привязана задача, сначала необходимо удалить все связанные с этим пакетом задачи!
Создание задачи на основе пакета:
После загрузки пакета можно создать связанную с ним задачу. Для этого выделите в списке нужный пакет и нажмите кнопку "Создать задачу" в верхней панели. В открывшемся окне необходимо указать сервер и строку выполнения (для обычного пакета), остальные параметры подставляются автоматически:
  • •
    Название - берется из названия пакета;
  • •
    Проект - подставляется тот, к которому относится пакет;
  • •
    Пакет - берется выделенный пакет.
Подробнее см. в разделе "Задачи".
Таблица списка пакетов содержит в себе следующие данные:
  • •
    Название - название пакета;
  • •
    Тип - тип пакета (простой пакет или Talend пакет);
  • •
    Дата создания - дата и время создания пакета;
  • •
    Проект - название проекта, к которому привязан данный пакет. Если поле пустое, пакет считается общим.
Добавление нового пакета:
Для добавления пакета нужно щелкнуть по кнопке "Добавить" в верхнем меню. Далее необходимо выбрать тип загружаемого пакета из выпадающего меню:
В открывшемся окошке необходимо ввести название пакета, выбрать проект, к которому будет принадлежать данный пакет:
После нажатия кнопки "Сохранить" пакет появится в списке и станет доступен для дальнейшей работы:
Выделение желтым цветом и подпись "нет активного файла" означает, что для данного пакета нет загруженных файлов. Для загрузки файла необходимо выделить нужный пакет и нажать кнопку "Добавить" в меню правой колонки:
Файл пакета можно перетащить в поле загрузки, или же кликнуть по иконке и выбрать файл из локального списка. После выбора файла он загрузится автоматически и появится в списке файлов, принадлежащих к выбранному пакету:
Управление файлами пакета:
После того, как пакет загружен, вы можете управлять его файлами, загружая новые и переключаясь на нужный с помощью радиокнопок (по умолчанию активным считается последний загруженный файл):
Также можно сохранить выбранный файл пакета на локальный компьютер (кнопка "Скачать").
Чтобы посмотреть информацию о файле пакета (дату и время загрузки, имя пользователя, который загрузил файл, размер файла) выделите нужный файл в списке, щелкнув по строке в гриде. В нижней правой части страницы выведется вся информация:
Пакеты типа Talend имеют дополнительное нередактируемое поле "Параметры", которые берутся из настроек проекта Talend:
Так как один пакет может быть привязан к нескольким задачам, параметры пакета редактируются во вкладке "Параметры" раздела "Задачи".


Задачи

В разделе "Задачи" осуществляется управление задачами: добавление новых задач, редактирование/удаление существующих, запуск и остановка задач, массовая пауза/запуск триггеров.
Также в таблице задач отображаются основные данные по запуску задач (статус, количество задействованных и активных триггеров, время запуска, информация о пакетах, серверах и проектах). Для расширенного мониторинга выполнения задач преусмотрен раздел "Выполнение задач" .
Верхняя панель управления содержит следующий функционал:
  • •
    Обновить - обновление данных грида;
  • •
    Добавить - добавление новой задачи;
  • •
    Копировать - сделать копию выбранной задачи;
  • •
    Редактировать - редактирование задачи;
  • •
    Удалить - удаление задачи;
  • •
    Запустить - ручной запуск задачи;
  • •
    Остановить - остановка выполнения задачи;
  • •
    Возобновить триггера - возобновить работу триггеров для выбранной задачи;
  • •
    Поставить на паузу триггера - приостановить работу триггеров для выбранной задачи.
Для редактирования, удаления, запуска/остановки задачи, паузы/возобновления триггеров необходимо сначала выделить нужную задачу в списке, после чего станут активными соответствующие кнопки.
Таблица списка задач содержит в себе следующие данные:
  • •
    Название - название задачи;
  • •
    Статус - статус выполнения задачи. "Готова" - задача выполнена, "Запущена" - задача выполняется в настоящий момент, "Ошибка" - возникла ошибка при выполнении задачи;
  • •
    Триггер - показывается общее количество триггеров, настроенных для данной задачи, и количество активных триггеров. Например, значение 1 из 3 показывает, что активен 1 триггер из 3.
  • •
    Следующий запуск - дата и время ближайшего запуска задачи;
  • •
    Предыдущий запуск - дата и время последнего запуска задачи;
  • •
    Пакет - название пакета, привязанного к данной задаче;
  • •
    Тип пакета - тип этого пакета (простой или Talend);
  • •
    Сервер - название сервера, на котором выполняется задача;
  • •
    Проект - название проекта, к которому привязана данная задача.
Добавление новой задачи
Чтобы создать новую задачу, щелкните по кнопке "Добавить" в верхней панели. В открывшемся окне заполните поля:
  • •
    Название - название задачи;
  • •
    Сервер - из выпадающего списка выберите сервер, на котором необходимо осуществлять запуск задачи;
  • •
    Проект - из выпадающего списка выберите проект, к которому необходимо привязать задачу;
  • •
    Пакет - из выпадающего списка выберите пакет, который необходимо запускать в рамках данной задачи;
  • •
    Директория запуска - поле неактивно, если выбран пакет. Заполняется при необходимости указать рабочую папку;
  • •
    Строка выполнения - командная строка для выполнения задачи. Поле неактивно, если выбран пакет типа Talend. Может подгружаться из предварительно созданного шаблона . Для загрузки строки выполнения из шаблона щелкните по кнопке [image] справа от поля "Строка выполнения" и выберите необходимый шаблон из открывшегося списка. Внимание! Если поле "Строка выполнения" заполнена, а после этого выбирается шаблон, то строка полностью заменится на ту, что указана в шаблоне!
    Если в строке выполнения указывается путь к запускаемому файлу, строку можно заполнить несколькими способами:
    1. Указать полный путь к файлу
    2. Если используется директория запуска или простой пакет, можно использовать тег {BASE_DIR}. Пример: {BASE_DIR}/название_файла
    3. Прописать для ОС Windows: cmd /c название_файла
    для ОС Linux: sh путь_к_файлу
Внимание! Рантайм сервер перехватывает консольный вывод запускаемого приложения для записи в лог, и если консольное приложение его не поддерживает, то может возникнуть ошибка. Для обхода таких ситуаций рекомендуется такие приложения запускать отдельным потоком из-под пакетного файла. Пример: START /WAIT CMD /C timeout 120
Данная рекомендация актуальна для Windows версии.
  • •
    Кодировка - в данной кодировке открывается лог истории задач;
  • •
    Описание - текстовый комментарий к задаче, заполняется по желанию.
После того, как задача создана, к ней можно привязать триггеры для автоматизации запуска задачи по расписанию, или же запускать и останавливать задачу вручную, по необходимости. Для остановки и запуска задач используйте соответствующие кнопки ("Запустить", "Остановить") в верхней панели. Для настройки триггеров используйте вкладку "Триггера" в нижней панели управления задачами.
Чтобы остановить или запустить все триггера, привязанные к задаче, выделите задачу в списке и используйте соответствующие кнопки ("Поставить на паузу триггера", "Возобновить триггера") в верхней панели управления.
Для отслеживания выполнения задачи используйте вкладку "История" в нижней панели управления.

Содержание Задачи

Правила
Триггера
История
Параметры
Java


Правила

Во вкладке "Правила" вы можете установить условия выполнения задач, настроить правила запуска, остановки, управлять последовательностью запуска задач.
Для установки правил задачи перейдите в пункт меню "Задачи", выберите нужную задачу и перейдите во вкладку "Правила":
Настройки правил:
1. Автоматическая остановка задачи.
Данное правило дает возможность указать время в минутах, по истечению которого выбранная задача будет автоматически остановлена вне зависимости от статуса ее выполнения.
Если это правило отрабатывает, происходит рассылка.
2. Оповещение о долгой работе задачи.
Данное правило позволяет настроить отправку оповещения по E-mail, если время выполнения задачи превысило заданное значение.
Внимание! Для получения оповещений необходимо подписаться на проект , к которому привязана нужная задача.
3. Автоматический запуск задачи
В данном разделе вы можете настроить автоматический запуск задачи в зависимости от статуса завершения текущей задачи.
4. Правила запуска задачи
В данном разделе вы можете настроить запрет запуска выбранной задачи в зависимости от статуса тех или иных задач. Можно задать маску имени задачи, прописав после первого или нескольких первых символов названий задач знак * ("звездочка"). Например, необходимо, чтобы выбранная задача не запускалась, если все задачи, начинающиеся на символ "t", имеют статус RUN, тогда форма заполняется следующим образом:


Триггера

Триггера позволяют настроить режим выполнения задач с необходимой частотой и количеством повторных запусков.
Для управления триггерами перейдите в пункт меню "Задачи", выделите нужную задачу в списке, затем перейдите во вкладку "Триггера":
Панель управления содержит следующий функционал:
  • •
    Обновить - обновление данных грида;
  • •
    Добавить - добавление нового триггера;
  • •
    Редактировать - редактирование триггера;
  • •
    Удалить - удаление триггера;
  • •
    Возобновить - возобновление выполнения триггера;
  • •
    Поставить на паузу - приостановка выполнения триггера.
Для редактирования, удаления, паузы/возобновления триггера необходимо сначала выделить нужный триггер в списке, после чего станут активными соответствующие кнопки.
Таблица списка триггеров содержит в себе следующие данные:
  • •
    Название - название триггера;
  • •
    Тип - тип триггера (SIMPLE - простой триггер, CRON - триггер CRON);
  • •
    Признак паузы - показывает, выполняется триггер ( [image]) или поставлен на паузу ( [image]);
  • •
    Статус - статус выполнения триггера: WAITING - нормальный статус, триггер ожидает запуска по заданному времени; PAUSED - триггер поставлен на паузу; ACQUIRED - триггер, определенный планировщиком как следующий в списке запуска; BLOCKED - триггер заблокирован до окончания выполнения другого триггера, с которым он пересекается);
  • •
    След. запуск - дата и время следующего запуска триггера;
  • •
    Старт - дата и время начала работы триггера;
  • •
    Финиш - дата и время окончания работы триггера.
Триггер отвечает только за запуск задачи, поэтому если поставить триггер на паузу или удалить во время выполнения задачи, это не повлияет на процесс.
Внимание! Триггеры, ограниченные по времени работы или количеству запусков, удаляются сразу после последнего запуска.
Добавление нового триггера
Для добавления нового триггера выделите нужную задачу в списке, затем перейдите во вкладку "Триггера" и щелкните по кнопке "Добавить". В выпадающем меню выберите тип триггера.
EasyScheduler поддерживает два типа триггеров: простые триггера и CRON триггера.
Простые триггеры используются, когда не нужна тонкая настройка запусков, а интервал между запусками фиксирован и неизменен. Например, вам нужно запускать задачу каждые 20 минут на протяжении недели. В подобном случае выберите из списка "Простой триггер" и в открывшемся окне заполните поля:
  • •
    Название - название триггера (обязательное поле);
  • •
    Срок действия - период времени, в течение которого будет запускаться задача. Если не указать дату начала работы триггера, то автоматически подставится текущая дата и время. Если не требуется ограничивать срок работы триггера, то не указывайте дату окончания, в таком случае триггер будет работать до ручной отмены;
  • •
    Интервал в минутах - промежуток времени между запусками (обязательное поле);
  • •
    Количество повторов - сколько раз задача будет запущена.
CRON триггеры
Триггеры CRON дают возможность более точного планирования, чем простые триггеры, но также не являются слишком сложными. Основываясь на выражениях cron, триггер дает возможность устанавливать интервалы повторов в календарном виде, а не в стандартном, что является значительным улучшением по сравнению с простыми триггерами. Если вам нужна тонкая настройка интервалов между выполнениями задачи, выберите в выпадающем списке CRON триггер.
В открывшемся окне заполните обязательное поле "Название" и настройте триггер как вам необходимо.
Ручная настройка:
Триггеры CRON используют серию специальных символов, которые могут быть использованы для тонкой настройки триггера. Например:
  • •
    Символ запятая (,) обозначает перечисление значений. Например, "5,6,7" в поле "Месяц" обозначает выполнение только в мае, июне и июле;
  • •
    Символ дефис (-) обозначает диапазон значений. Например, "12-15" в поле "Часы" обозначает выполнение в период с 12 по 15 часов;
  • •
    Символы запятая и дефис могут использоваться вместе. Например, "2-7,15" в поле "Дни месяца" обозначает выполнение в период с 2 по 7 число, а следующее выполнение будет 15 числа;
  • •
    Символ косая черта (/) обозначает приращение значения. Например, "5/15" в поле "секунды" означает каждые 15 секунд, начиная с пятой секунды.
  • •
    Знак вопроса (?) и букву L (L) разрешается использовать только в полях "день месяца" и "день недели". Знак вопроса означает, что в поле не должно быть указанной величины. Таким образом, если вы устанавливаете день недели, вы можете вставить "?" в поле "день недели" для обозначения того, что значение "день недели" несущественно. Буква L - это сокращение от last (последний). Если она помещается в поле "день месяца", задание будет запланировано на последний день месяца. В поле "день недели" "L" равнозначно "7", если помещается само по себе, или означает последний экземпляр "дня недели" в этом месяце. Так, "0L" запланирует выполнение задания на последнее воскресенье данного месяца.
  • •
    Буква W (W) в поле "день месяца" планирует выполнение задания на ближайший к заданному значению рабочий день. Введя "1W" в поле "день месяца" вы планируете выполнение задания на рабочий день, ближайший к первому числу месяца.
  • •
    Знак фунта (#) устанавливает конкретный рабочий день данного месяца. Ввод "MON#2" в поле "день недели" планирует задание на второй понедельник месяца.
  • •
    Знак астериска (*) является подстановочным знаком и обозначает, что любое возможное значение может быть принято для данного отдельного поля.
Поле "Год" не обязательно для заполнения, в остальных полях должны быть указаны значения. Если оставить поле пустым, оно будет автоматически заполнено соответствующими подстановочными значениями (? и * в зависимости от поля).
Внимание! Если в поле "Дни недели" использовать цифровые значения, то 1-й день приходится на воскресенье.
Настройка через календарь:
Для удобства настройки триггера EasyScheduler поддерживает визуальную планировку с помощью календаря. Для того, чтобы открыть календарь, щелкните по иконке [image] в окне настройки триггера. В открывшемся окне выберите нужные значения для настройки триггера:
Календарь поддерживает стандартные функции множественного выделения при помощи клавиатуры (клавиши Shift и Ctrl).
После нажатия кнопки ОК выбранные значения подставятся в соответствующие поля в окне настройки триггера.
Нельзя одновременно выбрать дни недели и дни месяца, это ограничение CRON, т.к. данные параметры могут быть взаимоисключающими. При ручной настройке, если заполнен один из этих пунктов, то второй становится неактивным.
Использование шаблонов
Если вы часто используете одни и те же настройки триггеров, то удобно будет "запомнить" их с помощью шаблонов. Сохраненные шаблоны триггеров можно выбрать из выпадающего списка "Шаблоны". После выбора шаблона поля настроек заполнятся автоматически, а в название триггера подставится название шаблона:
После того, как вы осуществили настройку триггера, нажмите кнопку "Сохранить". Созданный триггер появится в списке триггеров, а его запуск начнется автоматически при наступлении заданного времени. Все запуски задач пишутся в Историю и их можно просмотреть в соответствующей вкладке.
Редактирование триггеров
Если вам необходимо произвести редактирование созданного триггера, выделите в списке задачу, к которой он относится, затем перейдите во вкладку "Триггера" в нижней панели управления:
Выделите в списке необходимый триггер и нажмите кнопку "Редактировать", в открывшемся окне произведите необходимые изменения:
Созданные триггеры можно ставить на паузу или же возобновлять запуск приостановленных триггеров при помощи соответствующих кнопок на панели управления триггерами.


История

История задач показывает статус выполнения задачи, время начала и окончания выполнения:
Для просмотра истории необходимо выбрать задачу в списке в разделе Задачи и перейти во вкладку "История".
Верхняя панель управления содержит следующий функционал:
  • •
    Обновить - обновление данных грида (таблица истории не перегружается автоматически - для обновления необходимо нажать кнопку "Обновить");
  • •
    Удалить всю историю - удаление всей истории для данной задачи; Внимание! Перед удалением истории убедитесь, что задача не запущена.
  • •
    Информация - лог выполнения задачи, открывающийся в модальном окне. Этот лог имеет ограниченную длину (указывается в настройках);
  • •
    Лог - расширенная информация о задаче. Показывает помимо лога выполнения задачи такую информацию, как название сервера, статус выполнения задачи, статус запуска, время начала и окончания запуска, код завершения. Этот лог имеет свою длину (указывается в настройках).
  • •
    Скачать лог - скачивание лога в виде отдельного txt файла; Внимание! Скачать лог можно только после завершения задачи.
  • •
    Показывать полную историю - отображение расширенной истории выполнения задач. По умолчанию в таблице показывается ограниченное количество записей (указывается в настройках истории задач), не отображаются повторные запуски и задачи, запущенные в то время, когда сервер был неактивен. В полной истории показывается вся история запусков, включая повторные запуски и попытки запуска в период неактивности сервера.
Таблица истории задач содержит в себе следующие данные:
  • •
    ID - уникальный идентификационный номер записи в истории задач;
  • •
    Рантайм сервер - название сервера, на котором происходил запуск задачи. Если используется группа серверов, в названии сначала указывается название группы, а в скобках - названия серверов.
  • •
    Статус - RUN - задача выполняется, FINISHED - задача выполнена, STOP - задача остановлена, ERROR - задача выполнена с ошибками, SERVER_NOT_ACTIVE - сервер неактивен, DOUBLE_RUN - повторный запуск, BLOCKING - заблокировано правилами;
  • •
    Статус запуска - тип запуска задачи: AUTO - автоматический запуск по расписанию с помощью триггеров; HAND - ручной запуск задачи;
  • •
    Начало - дата и время старта задачи;
  • •
    Окончание - дата и время окончания выполнения задачи;
  • •
    Код завершения - код завершения cmd команды.


Параметры

Вкладка "Параметры" активна только для задач с пакетами Talend.
Описание параметров задачи:
  • •
    Активность - чекбокс, определяющий, будет ли данный параметр передаваться при выполнении задачи. Активность меняется снятием/установкой чекбокса, изменения сохраняются автоматически (оповещение об успешном изменении активности отображается в правой верхней части экрана в виде всплывающей подсказки);
  • •
    Название - неизменяемое значение, берется из настроек проекта Talend;
  • •
    Новое значение - измененное значение параметра, его можно изменить, щелкнув мышкой по строке параметра в колонке "Новое значение", в появившейся строке редактирования прописать новое значение параметра:
  • •
    Значение по умолчанию - исходное значение параметра, берется из настроек проекта Talend.


Java

Для передачи параметров запуска java приложения при загрузке Talend пакетов в EasyScheduler предусмотрена вкладка Java:
Чтобы указать параметры запуска java, перейдите в раздел "Задачи", выделите нужную задачу и перейдите во вкладку Java. Параметры вписываются одной строкой.


Мониторинг

Через интерфейс EasyScheduler доступна следующая информация:
  • •
    Ход выполнения текущих задач с возможностью фильтрации и сортировки по нужным параметрам;
  • •
    История выполнения задач с возможностью фильтрации по серверам и проектам за определенную дату в пределах суток;
  • •
    Статистика нагрузки на рантайм сервера за определенную дату в пределах суток;
    Для просмотра статистики по истории задач или нагрузке на сервера выберите сервер, по которому следует показать данные, и дату, за которую нужно отобразить статистику.

Содержание Мониторинг

Выполнение задач
История задач
Ресурсы серверов


Выполнение задач

Раздел мониторинга предназначен для отслеживания задач. Также в разделе мониторинга можно поставить на паузу или возобновить выполнение триггеров, остановить выполнение задачи, посмотреть или скачать лог последнего запуска задачи.
Верхняя панель управления содержит следующий функционал:
  • •
    Обновить - обновление данных грида;
  • •
    Возобновить триггера - возобновить работу триггеров для выбранной задачи;
  • •
    Поставить на паузу триггера - приостановить работу триггеров для выбранной задачи;
  • •
    Остановить - остановка выполнения задачи;
  • •
    Лог в новом окне - показывает помимо лога выполнения задачи такую информацию, как название сервера, статус выполнения задачи, статус запуска, время начала и окончания запуска, код завершения. Этот лог имеет свою длину (указывается в настройках);
  • •
    Скачать лог - скачивание лога в виде отдельного txt файла; Внимание! При скачивании лога в процессе выполнения задачи, лог будет урезан так же, как "Лог в новом окне".
Таблица списка задач содержит в себе следующие данные:
  • •
    Название - название задачи;
  • •
    Статус - статус выполнения задачи. "Готова" - задача выполнена, "Запущена" - задача выполняется в настоящий момент, "Ошибка" - возникла ошибка при выполнении задачи;
  • •
    Триггер - показывается общее количество триггеров, настроенных для данной задачи, и количество активных триггеров. Например, значение 1 из 3 показывает, что активен 1 триггер из 3.
  • •
    Следующий запуск - дата и время ближайшего запуска задачи;
  • •
    Предыдущий запуск - дата и время предыдущего запуска задачи;
  • •
    Пакет - название пакета, привязанного к данной задаче;
  • •
    Тип пакета - тип этого пакета (простой или Talend);
  • •
    Сервер - название сервера, на котором выполняется задача;
  • •
    Проект - название проекта, к которому привязана данная задача.
В режиме мониторинга доступна расширенная фильтрация по большинству полей: по пакетам, типам пакетов, серверам, проектам, статусам выполнения задач. Также доступен поиск по названию задачи.
Задачи отображаются в зависимости от статуса пользователя: администратор видит все задачи независимо от прав доступа к проектам, пользователи видят только те задачи, к которым у них есть доступ через соответствтующие проекты.


История задач

В разделе "Мониторинг / История задач" отображается история выполнения задач за 1 сутки:
–
Для просмотра статистики выполнения задач, в правой части страницы нужно выбрать сервер, проект и дату, по которым следует отображать данные. Если сервер и/или проект не выбраны, покажется статистика по всем проектам и/или серверам за выбранную дату.
Цвет задач на графике отображается в зависимости от статуса их выполнения:
  • •
    Синий - задача выполнена без ошибок;
  • •
    Красный - задача выполнена с ошибкой;
  • •
    Зеленый - задача выполняется в настоящий момент.
При наведении на задачу показывается дата и время начала и окончания выполнения данной задачи.
Внимание! Скорость подгрузки истории зависит от количества задач на сервере - чем больше задач, тем дольше они загружаются и медленнее работает мониторинг.


Ресурсы серверов

В разделе "Мониторинг / Ресурсы серверов" отображается расход процессорных мощностей и памяти за 1 сутки:
Чтобы просмотреть статистику, в правой части страницы необходимо выбрать сервер и дату, по которым нужно отобразить данные. Статистика доступна только для активных серверов.
Внимание! Данные по статистике серверов хранятся 10 дней


Профиль пользователя

Персональный раздел для настроек личной информации пользователя, а также включение/отключение подписки на рассылку.
Личные данные
Раздел персональных данных пользователя. Здесь вы можете изменить E-mail, пароль, имя пользователя, включить или отключить получение рассылки по задачам:
Имя пользователя в AD - используется для доменной авторизации. Для того, чтобы это поле было активным, необходимо прописать соответствующие настройки в файле конфигурации.
Подписка на рассылку
В этом разделе пользователь может настроить получение рассылки по необходимым проектам:


Настройки

В интерфейсе EasyScheduler доступны следующие настройки:
  • •
    Пользователи - добавление новых пользователей и редактирование информации о существующих;
  • •
    История задач - настройка параметров сохранения истории выполнения задач;
  • •
    SMTP - настройки SMTP сервера, который отвечает за рассылку почты;
  • •
    Шаблоны триггеров - создание и редактирование шаблонов для быстрой настройки триггеров;
  • •
    Шаблоны выполнения - создание и редактирование шаблонов выполнения командной строки.
Внимание! Данный раздел доступен только администраторам!

Содержание Настройки

Пользователи
История задач
SMTP
Шаблоны триггеров
Шаблоны выполнения


Пользователи

Добавление и редактирование пользователей осуществляется администратором через пункт меню "Пользователи" раздела "Настройки":
Для добавления нового пользователя щелкните по кнопке "Добавить" в верхней панели. В открывшемся окне следует ввести данные о пользователе:
  • •
    EMail - адрес электронной почты пользователя;
  • •
    Пароль - пароль пользователя;
  • •
    Подтверждение - подтверждение пароля пользователя, должно совпадать с данными, введенными в поле "Пароль";
  • •
    Полное имя - имя пользователя;
  • •
    Активность - признак активности пользователя;
  • •
    Администратор - принадлежность пользователя к роли "Администратор";
  • •
    Получать письма с ошибками - включение/выключение рассылки ошибок для пользователя;
  • •
    Описание - комментарий к профилю пользователя.
Редактирование данных пользователя и смена пароля через раздел "Список пользователей" осуществляется только администраторами. Для редактирования данных существующего пользователя нужно выделить пользователя в списке и нажать кнопку "Редактировать" в верхней панели.
Для удаления пользователя нужно выделить его в списке и нажать кнопку "Удалить" в верхней панели.
Внимание! Нельзя удалить пользователя, если им были созданы сервера, пакеты, проекты или задачи. Если необходимо ограничить доступ какого-то пользователя, его следует сделать неактивным (снять галочку "Активность" в окне редактирования информации о пользователе). Или пересоздать связанные с пользователем сервера, пакеты или задачи от имени другого пользователя.
Пользователь может самостоятельно изменить пароль, имя, E-mail, настроить подписки на рассылки в персональном разделе своего профиля.


История задач

Настройки позволяют регулировать параметры истории выполнения задач:


SMTP

Раздел используется для настроек SMTP сервера, который отвечает за рассылку писем:


Шаблоны триггеров

Шаблоны триггеров позволяют сохранять наиболее часто использующиеся CRON настройки триггера и в дальнейшем быстро подключать их к задачам.
Для создания нового шаблона триггера перейдите в пункт меню "Шаблоны триггеров" в разделе "Настройки":
Далее щелкните по кнопке "Добавить" в верхней панели.
В открывшемся окне заполните следующие поля:
  • •
    Название - название шаблона триггера;
  • •
    Минуты/Месяц/Часы/Дни недели/Дни месяца/Год - CRON настройки триггера. Подробнее о возможностях настроек CRON описано в разделе "Триггера".
После настройки шаблона триггера нажмите кнопку "Сохранить" и шаблон появится в списке. Теперь его можно использовать для быстрой подгрузки настроек CRON триггеров в задачах:
Внимание! При подгрузке шаблона название триггера заменится на название шаблона.


Шаблоны выполнения

Шаблоны выполнения командной строки предназначены для быстрой подгрузки часто используемых строк запуска в задачах.
Для создания нового шаблона перейдите в пункт меню "Шаблоны выполнения" в разделе "Настройки":
Далее щелкните по кнопке "Добавить" в верхней панели. В открывшемся окне заполните поля:
  • •
    Название - название шаблона;
  • •
    Шаблон - команда выполнения.
Пример:
После нажатия кнопки "Сохранить" шаблон выполнения появится в списке шаблонов и его можно будет использовать для быстрого заполнения строки выполнения в задачах:


Доверенный сертификат

Создание сертификата:
1. Создать набор криптографических ключей и сохранить его в хранилище (keytool -genkeypair -alias EasySchedulerTomcat -keyalg RSA -keysize 2048 -storetype PKCS12 -keystore keystore.p12 -validity 3650)
2. В корневой директории шедулера, создать или отредактировать файл application-prod.properties
• server.ssl.key-store-password=password – пароль от хранилища
• server.ssl.key-store=ssl/keystore.p12 – путь к хранилищу
• server.ssl.key-alias=EasySchedulerTomcat – псевдоним сертификата
Импорт доверенного сертификата:
Чтобы избавиться от предупредительной страницы при подключении к шедулеру, необходимо импортировать доверенный сертификат в свой Центр сертификатов.
Для этого необходимо импортировать файл truststore.cer, который находится в директории ssl, где установлен шедулер, в Центр сертификатов в раздел «Доверенные корневые центры сертификации»:
После этого нужно перезапустить браузер.


Администрирование

Установка EasyScheduler
Требования
Установка WebCenter и EasyRuntime под Windows
Установка WebCenter под Linux
Настройка файла параметров WebCenter
Настройка файла конфигурации WebCenter
Создание учетной записи администратора
Подключение рантайм сервера к веб центру EasyScheduler
Установка агента EasyRuntime
Требования
Установка EasyRuntime под Windows
Установка EasyRuntime под Linux
Настройка файла параметров EasyRuntime
Настройка файла конфигурации EasyRuntime

Содержание Администрирование

Установка EasyScheduler
Установка агента EasyRuntime


Установка EasyScheduler

Требования
Установка WebCenter и EasyRuntime под Windows
Установка WebCenter под Linux
Настройка файла параметров WebCenter
Настройка файла конфигурации WebCenter
Создание учетной записи администратора
Подключение рантайм сервера к веб центру EasyScheduler

Содержание Установка EasyScheduler

Требования
Установка WebCenter и EasyRuntime под Windows
Установка WebCenter под Linux
Настройка файла параметров WebCenter
Настройка файла конфигурации WebCenter
Создание учетной записи администратора
Подключение рантайм сервера к веб центру EasyScheduler


Требования

Для корректной работы EasyScheduler в firewall должны быть открыты следующие порты:
  • 1.
    Работа клиентов через веб интерфейс: 9090;
  • 2.
    Управление задачами на Runtime серверах: 9200, 9201;
  • 3.
    Обмен файлами пакетов и логов между WebCenter и Runtime серверами: 9221 и список пассивных портов 50000-50100.


Установка WebCenter и EasyRuntime под Windows

Для операционной системы Windows доступен визуальный инсталлятор, который позволяет пошагово указать нужные параметры и автоматически установить EasyScheduler сервисом операционной системы.
Для установки EasySheduler, перейдите в браузере на портал https://easyportal.ru. Во вкладке EasySheduler нажмите "Скачать". Выберите и скачайте файл инсталляции для Windows:
Запустите скаченный файл инсталляции:
Если система Windows Defender или установленный антивирус при запуске запросят подтверждения установки, подтвердите, что разрешаете запуск. Устанавливаемое ПО гарантирует отсутствие вирусов и подписано цифровой подписью сертификата компании EasyData, зарегистрированного в мировых центрах сертификации. Однако в силу причин расположения на территории Российской Федерации, сертификаты все равно могут считаются не проверенными. Можно проверить, что скаченный файл инсталляции является подлинным, открыв цифровые подписи в окне свойства файла из проводника Windows:
P.S. Каждый установленный выполняемый файл после инсталляции так же будет иметь цифровую подпись доверенным сертификатом.
Выберите путь установки ПО. По умолчанию установка осуществляется в каталог установки 64 разрядных приложений Windows:
P.S. Важно: для корректной работы EasyScheduler в пути установки не должно содержаться национальных символов, допускается ипсользовать только латинские символы!
При установке EasyScheduler предлагается установить два компонента:
  • •
    WebCenter - веб сервер визуального управления задачами EasyScheduler на серверах
  • •
    RuntimeServer - агент запуска задач на серверах, которые определены в EasyScheduler
По умолчанию выбраны оба компонента. Предполагается, что на устанавливаемом сервере будет работать веб центр управления задачами EasyScheduler и на этом же сервере запускаться сами задачи с помощью RuntimeServer. Если не планируется запускать задачи на устанавливаемом сервере, а только управлять задачами на других серверах, то можно отказаться от установки RuntimeServer.
P.S. Внимание, для Community редакции EasyScheduler поддерживается запуск задач только на том же сервере, где он установлен. Не снимайте галочку с компонента RuntimeServer!
Укажите используемый сетевой интерфейс для управления другими внешними серверами:
По умолчанию сервисы после инсталляции автоматически запустятся. Снимите галочку с автоматического запуска, если требуется произвести какие-то дополнительные действия до запуска сервисов: переназначить правила запуска, рестарт и авторизацию установленным сервисам, изменить файлы настроек конфигурации EasyScheduler.
Если EasyScheduler будет запускать задачи только на своем сервере, укажите используемый сетевой TCP/IP интерфейс управления задачами localhost.
Если требуется управления задачами на других, внешних серверах, нужно задать TCP/IP V4 адрес сервера, который используется в сетевом интерфейсе ОС. Для определения требуемого сетевого интерфейса в окне командной строки можно просмотреть список доступных интерфейсов с помощью команды Ipconfig:
P.S. Если на сервере установлено несколько сетевых интерфейсов, требуется выбрать тот, через который идет связь с другими внешними серверами, на которых требуется запускать задачи, так как EasyScheduler не поддерживает работу в нескольких сетях одновременно.
В ходе установки требуется указать, под какой лицензией будет работать EasyScheduler:
При выборе бесплатной редакции Community указывать лицензию не требуется.
Если же выбрана лицензия Enterprise, то далее потребуется задать директорию, где лежат присланные компанией EasyData файлы коммерческой лицензии:
Перед непосредственной установкой ПО можно проверить корректность параметров установки и вернуться назад, если требуется их изменить:
Если автоматический старт сервисов не был выбран, то после завершения инсталляции и настройки необходимо вручную стартовать сервисы easyscheduler и easyruntimeserver с помощью менеджера задач Windows или панель управления сервисами:
Когда сервисы успешно запущены, можно проверить работу EasyScheduler. Для этого в браузере перейдите по ссылке: https://localhost:9090 . При успешной установке и старте сервисов появится режим создания учетной записи администратора EasyScheduler:
Если EasyScheduler недоступен в браузере и его сервис остановлен, то ошибки запуска сервиса можно посмотреть в логе файла "<Путь установки>\EasyScheduler\server\easyscheduler-error.log":
Если не удается установить причину отказа запуска сервиса, потребуется переслать этот файл вендору для установки причины ошибки.


Установка WebCenter под Linux

Для Linux систем поддерживается установка с помощью пакетных менеджеров "rpm" для RedHat/CentOS и "apt" для Debian/Ubuntu.
Для установки WebCenter, перейдите в браузере на портал https://easyportal.ru. Во вкладке EasySheduler нажмите "Скачать". Выберите и скачайте файл инсталляции EasyScheduler для нужной редакции Linux:
Закачайте полученный пакет инсталляции на Linux сервер.

Установка в Linux RedHat/CentOS

Запустите из-под пользователя, имеющего права sudo следующую команду:
sudo rpm -i /<путь к пакету>/EasyScheduler_linux_1_10_12.rpm
По умолчанию EasyScheduler будет установлен по пути "/opt/easydata/easyscheduler". Если требуется установить ПО в другой директорий, используйте параметр "--prefix":
sudo rpm -i --prefix=<путь установки> /<путь к пакету>/EasyScheduler_linux_1_10_12.rpm

Установка в Linux Debian/Ubuntu

Запустите из-под пользователя, имеющего права SUDO следующую команду:
sudo apt install /<путь к пакету>/EasyScheduler_linux_1_10_12.deb
По умолчанию EasyScheduler будет установлен по пути "/opt/easydata/easyscheduler". Если требуется установить ПО в другой директорий, то создайте перед установкой директорий в нужном месте и сделайте на него директория "/opt/easydata/easyscheduler".

Настройки после установки

Откройте файл параметров запуска "/opt/easydata/easyscheduler/server/easyscheduler.vmoptions" и укажите в параметре "-Djava.rmi.server.hostname" TCP/IP V4 текущий адрес сервера, по которому WebCenter будет обмениваться данными с внешними EasyRuntime серверами. Если внешних серверов нет, можно оставить "localhost".
Если требуется изменить конфигурацию работы WebCenter , внесите изменения в файл "/opt/easydata/easyscheduler/server/application.properties".

Запуск WebCenter

Запустите из-под пользователя, имеющего права sudo следующую команду:
systemctl start easyscheduler
Для проверки состояния сервиса выполните следующую команду:
systemctl status easyscheduler

Проверка работы веб интерфейса

В браузере своей машины перейдите по ссылке: https://хостсервера:9090 . При успешной установке и старте сервиса появится режим создания учетной записи администратора EasyScheduler:
P.S. Если EasyScheduler недоступен в браузере и его сервис остановлен, то ошибки запуска сервиса можно посмотреть в логе файла /opt/easydata/easyscheduler/server/easyscheduler-error.log".


Настройка файла параметров WebCenter

При установке EasyScheduler устанавливается файл параметров запуска WebCenter по пути "<Путь установки>/EasyScheduler/server/easyscheduler.vmoptions". В этом файле можно добавить или изменить следующие параметры:
Название
Описание
-Djava.rmi.server.hostname
TCP/IP V4 сетевой адрес сервера, по которому WebCenter будет работать с внешними EasyRuntime серверами запуска задач.
-Xmx<Количество>
Максимальный размер памяти, который WebCenter может забирать у ОС. Количество задается как число с суффиксом M (мегабайты) или G (гигабайты).
По умолчанию используется 512 мегабайт (512M).
Если на EasyScheduler планируется запускать одновременно более пяти десятка задач, рекомендуется увеличить размер памяти из расчета на десять одновременно работающих задач плюс 50 мб памяти.


Настройка файла конфигурации WebCenter

При установке EasyScheduler устанавливается файл конфигурации по пути "<Путь установки>/EasyScheduler/server/application.properties". В этом файле описаны параметры работы WebCenter по умолчанию. Перед первым запуском сервиса можно отредактировать этот файл, если требуется переназначить часть этих параметров:
Название
Описание
scheduler.locale
Язык интерфейса:
  • •
    ru - русский (по умолчанию)
  • •
    en - английский
spring.datasource.url
JDBC строка подключения к базе данных H2 Database хранения метаданных, по умолчанию база располагается в директории "DB" по пути установки WebCenter.
Рекомендуется изменить, если требуется вынести файлы H2 Database в другую директорию или запустить это РСУБД как внешний сервис. Если параметр изменяется, требуется перенести текущую копию БД в новое место или сделать резервную копию-восстановление на новом месте.
spring.datasource.username
Имя пользователя базы данных хранения метаданных, по умолчанию "sa".
spring.datasource.password
Пароль пользователя базы данных хранения метаданных.
scheduler.package.storage
Путь к хранилищу пакетов задач. По умолчанию пакеты хранятся по пути установки в директории "server/storage/package".
Рекомендуется изменить, если требуется вынести хранение архивов пакетов в другую директорию. Если параметр изменяется на уже работающей версии, требуется скопировать все файлы текущей директории в новое место, чтобы EasyScheduler не потерял загруженные файлы пакетов.
scheduler.task-history-log.storage
Путь к директорию для хранения логов истории задач.
По умолчанию логи выполненных задач хранятся по пути установки в директории "server/storage/task_history_log".
Рекомендуется изменить, если требуется хранить логи в другой директории.
scheduler.temp
Путь к временной директории хранения промежуточных файлов.
По умолчанию используется директория с переменной среды "temp" операционной системы.
scheduler.backup.enabled
Флаг включения задачи резервного копирования базы хранения метаданных.
По умолчанию true.
scheduler.backup.storage
Путь к каталогу резервных копий базы хранения метаданных.
По умолчанию резервные копии хранятся по пути установки WebCenter в каталоге "backup".
scheduler.backup.cron
Cron расписание выполнения резервных копий базы хранения метаданных.
По умолчанию задано делать резервную копию каждую ночь в 2:30. В строке через пробел разделяются следующие параметры времени:
  • 1.
    Секунды
  • 2.
    Минуты
  • 3.
    Часы
  • 4.
    Номер дня в месяце
  • 5.
    Номер месяца в году
  • 6.
    Номер дня в неделе (где 1 - воскресенье, 2 - понедельник, ...)
  • 7.
    Год (опционально)
Каждую позицию можно задать константой, периодом, плавающей или всегда выполняемой:
  • •
    Число - выполнять при достижении числа;
  • •
    Число1, Число2, Число3 ... - выполнять при достижении одного из числа;
  • •
    Число1-ЧислоN - выполнять при достижении заданного промежутка;
  • •
    * - выполнять при каждом значении
  • •
    ? - не задавать указание
Пример:
0 30 8-20 4,1 * ? *
Выполнять каждый час с 8 до 20 (8-20) в 30 минут 0 секунд (0 30) в среду и воскресенье (4, 1) .
scheduler.backup.db-max-file
Количество хранимых файлов резервных копий.
По умолчанию хранится 7 копий.
scheduler.backup.package-delete-old
Очищать устаревшие файлы пакеты, которые более нигде не используются.
По умолчанию true.
scheduler.ftp-server.port
Порт обмена файлами пакетов WebCenter с агентами EasyRuntime.
По умолчанию 9221.
Можно изменить, если этот порт на сервере занят другим приложением. При изменении потребуется изменить в конфигурационных файлах EasyRuntime.
scheduler.ftp-server.passive.ports
Диапазон сервисных портов для связи WebCenter с агентами EasyRuntime.
По умолчанию задано "50000-50100".
Можно изменить, если этот пул портов занят другим приложением.
scheduler.rmi.port
Порт управления WebCenter агентами EasyRuntime.
По умолчанию 9200.
Можно изменить, если этот порт на сервере занят другим приложением.
scheduler.rmi.scheduler-management.port
Сервисный порт WebCenter для работы с агентами EasyRuntime.
По умолчанию 9201.
Можно изменить, если этот порт на сервере занят другим приложением.
server.port
HTTPS порт интерфейса WebCenter.
По умолчанию 9090.
Можно изменить, если этот порт на сервере занят другим приложением. После изменения в браузере веб интерфейс будет доступен по новому порту.
server.ssl.enabled
Работать в режиме SSL.
По умолчанию включено.
Если требуется переключить веб сервер в режим HTTP вместо HTTPS, установите параметр в false.
scheduler.authentication.ad.service-principal
Адрес LDAP сервера сквозной аутенфикации.
scheduler.authentication.ad.keytab-location
Путь к файлу для подключения к LDAP с форматом "keytab".
scheduler.authentication.ad.enable
Аутенфикация через LDAP сервер.
По умолчанию выключено.
spring.mail.host
Имя хоста SMTP сервера. Задается для рассылки почтовых уведомлений EasyScheduler пользователям.
spring.mail.port
Порт SMTP сервера.
По умолчанию 465.
spring.mail.properties.mail.smtp.auth
Использовать при работе с SMTP сервером авторизацию.
По умолчанию выключено.
spring.mail.username
Имя учетной записи SMTP сервера. Задается, если сервер требует авторизации.
spring.mail.password
Пароль учетной записи SMTP сервера. Задается, если сервер требует авторизации.
spring.mail.properties.mail.smtp.timeout
Таймаут ожидания ответа SMTP сервера в миллисекундах.
По умолчанию 10000 (10 сек).
spring.mail.properties.mail.smtp.starttls.enable
Разрешить работать с SMTP сервером через TLS.
По умолчанию выключено.
spring.mail.properties.mail.smtp.starttls.required
При работе с SMTP сервером проверять, что он поддерживает работу через TLS.
spring.mail.properties.mail.smtp.ssl.enable
Работать с SMTP сервером через SSL.
По умолчанию выключено.
spring.mail.properties.mail.smtp.ssl.trust
Путь к файлу доверенного сертификата SSL.


Создание учетной записи администратора

При первом подключении EasyScheduler в браузере откроется форма создания администратора портала. В ней потребуется ввести Ваш почтовый ящик, который будет использован как логин, придумать пароль и указать ФИО.
P.S. Внимание, указывайте существующий email и сохраните себе придуманный пароль, чтобы Вы могли в дальнейшем получить доступ к системе.
После создания учетной записи система предложит войти под созданным пользователем:
После входа в систему Вы попадете в панель управления центром задач:
Для дальнейшей работы потребуется подключить локальный рантайм сервер, установленный вместе с веб-центром , с помощью которого будут запускаться выполняемые задачи.


Подключение рантайм сервера к веб центру EasyScheduler

Перейдите в раздел "Рантайм сервера" и нажмите кнопку "Добавить":
Опишите подключение к локальному или внешнему серверу, на который был установлен агент EasyRuntimeServer:
При подключении Runtime сервер управления задачами остается не активным, что отражается в его статусе. Щелкните на сервер, выделив его и нажмите кнопку "Запустить":
Подтвердите запуск сервера и как процесс закончится, после сообщения "Сервер стартовал успешно", нажмите кнопку "Обновить", чтобы увидеть статус запущенного сервера:
P.S. Если сервис не смог стартовать, то требуется проверить, запущен ли на указанном хосте сервера сервис easyruntimeserver. Если сервис запущен, но центр все равно не может запустить рантайм сервер, по пути установки Runtime Server требуется просмотреть ошибки в файле лога "<Путь установки>\runtime\log\launcher-дата.log" и "<Путь установки>\runtime\log\runtime-дата.log":


Установка агента EasyRuntime

Требования
Установка EasyRuntime под Windows
Установка EasyRuntime под Linux
Настройка файла параметров EasyRuntime
Настройка файла конфигурации EasyRuntime

Содержание Установка агента EasyRuntime

Требования
Установка EasyRuntime под Windows
Установка EasyRuntime под Linux
Настройка файла параметров EasyRuntime
Настройка файла конфигурации EasyRuntime


Требования

Для корректной работы EasyRuntime в firewall должны быть открыты следующие порты:
  • •
    Для агента управления сервисов выполнения задач: 9100, 9101;
  • •
    Для сервиса управления запуском задач: 9082, 9983.


Установка EasyRuntime под Windows

Для операционной системы Windows доступен визуальный инсталлятор, который позволяет пошагово указать нужные параметры и автоматически установить EasyRuntime сервисом операционной системы.
Для установки EasyRuntime, перейдите в браузере на портал https://easyportal.ru. Во вкладке EasySheduler нажмите "Скачать". Выберите и скачайте файл инсталляции для Windows:
Запустите скаченный файл инсталляции:
Если система Windows Defender или установленный антивирус при запуске запросят подтверждения установки, подтвердите, что разрешаете запуск. Устанавливаемое ПО гарантирует отсутствие вирусов и подписано цифровой подписью сертификата компании EasyData, зарегистрированного в мировых центрах сертификации. Однако в силу причин расположения на территории Российской Федерации, сертификаты все равно могут считаются не проверенными. Можно проверить, что скаченный файл инсталляции является подлинным, открыв цифровые подписи в окне свойства файла из проводника Windows:
P.S. Каждый установленный выполняемый файл после инсталляции также будет иметь цифровую подпись доверенным сертификатом.
Выберите путь установки ПО. По умолчанию установка осуществляется в каталог установки 64 разрядных приложений Windows:
P.S. Важно: для корректной работы EasyScheduler в пути установки не должно содержаться национальных символов, допускается ипсользовать только латинские символы!
Снимите галочку с компонента WebCenter, чтобы установить только сервис EasyRuntime:
Укажите используемый сетевой интерфейс, который будет использован для связи с WebCenter:
Для определения требуемого сетевого интерфейса можно в окне командной строки просмотреть список доступных интерфейсов с помощью команды Ipconfig:
P.S. Если на сервере установлено несколько сетевых интерфейсов, требуется выбрать тот, через который идет связь с установленным сервером WebCenter, так как EasyRuntime не поддерживает работу в нескольких сетях одновременно.
По умолчанию сервис после инсталляции автоматически запустится. Снимите галочку с автоматического запуска, если требуется произвести какие то дополнительные действия до запуска сервиса: переназначить правила запуска, рестарт и авторизацию установленным сервисам, изменить файлы настроек конфигурации EasyRuntime.
Проверьте перед началом установки выбранные параметры:
Если автоматический старт сервиса не был выбран, то после завершения инсталляции и настройки необходимо вручную стартовать сервис easyruntimeserver с помощью менеджера задач Windows или панель управления сервисами:
Чтобы удостовериться, что сервис корректно работает, можно проверить файл по пути установки EasyScheduler "<Путь установки>\runtime\log\launcher-<дата>.log":

Логи ошибок

  • •
    Если сервис EasyRuntime будет остановлен, то ошибки запуска сервиса можно посмотреть в логе файла "<Путь установки>\runtime\easyruntime-error.log".
  • •
    Если сервер EasyRuntime не будет доступен в WebCenter при подключении рантайм сервера или он не сможет стартовать для выполнения задач, то ошибки работы можно будет посмотреть в лог файла WebCenter "<Путь установки>\server\log\easyscheduler-<дата>.log" и лог файлах EasyRuntime "<Путь установки>\runtime\log\launcher-<дата>.log" и "<Путь установки>\runtime\log\runtime-<дата>.log".


Установка EasyRuntime под Linux

Для Linux систем поддерживается установка с помощью пакетных менеджеров "rpm" для RedHat/CentOS и "apt" для Debian/Ubuntu.
Для установки EasySheduler, перейдите в браузере на портал https://easyportal.ru. Во вкладке EasySheduler нажмите "Скачать". Выберите и скачайте файл инсталляции EasyRuntime для нужной редакции Linux:
Закачайте полученный пакет инсталляции на Linux сервер.

Установка в Linux RedHat/CentOS

Запустите из-под пользователя, имеющего права sudo следующую команду:
sudo rpm -i /<путь к пакету>/EasyRuntime_linux_1_10_12.rpm
По умолчанию EasyScheduler будет установлен по пути "/opt/easydata/easyscheduler". Если требуется установить ПО в другой директорий, используйте параметр "--prefix":
sudo rpm -i --prefix=<путь установки> /<путь к пакету>/EasyRuntime_linux_1_10_12.rpm

Установка в Linux Debian/Ubuntu

Запустите из-под пользователя, имеющего права SUDO следующую команду:
sudo apt install /<путь к пакету>/EasyRuntime_linux_1_10_12.deb
По умолчанию EasyScheduler будет установлен по пути "/opt/easydata/easyscheduler". Если требуется установить ПО в другой директорий, то создайте перед установкой директорий в нужном месте и сделайте на него директория "/opt/easydata/easyscheduler".

Настройки после установки

Откройте файл параметров запуска "/opt/easydata/easyscheduler/runtime/easyruntime.vmoptions" и укажите в параметре "-Djava.rmi.server.hostname" TCP/IP V4 текущий адрес сервера, по которому EasyRuntime будет обмениваться данными с внешним центром управления задачами WebCenter. Если EasyRuntime и WebCenter располагаются на одном хосте, можно оставить "localhost".
Если требуется изменить конфигурацию работы EasyRuntime , внесите изменения в файл "/opt/easydata/easyscheduler/runtime/application.properties".

Запуск EasyRuntime

Запустите из-под пользователя, имеющего права sudo следующую команду:
systemctl start easyruntime
Для проверки состояния сервиса выполните следующую команду:
systemctl status easyruntime

Логи ошибок

  • •
    Если сервис EasyRuntime будет остановлен, то ошибки запуска сервиса можно посмотреть в логе файла "/opt/easydata/easyscheduler/runtime/easyruntime-error.log".
  • •
    Если сервер EasyRuntime не будет доступен в WebCenter при подключении рантайм сервера или он не сможет стартовать для выполнения задач, то ошибки работы можно будет посмотреть в лог файла WebCenter "/opt/easydata/easyscheduler/server/log/easyscheduler-<дата>.log" и лог файлах EasyRuntime "/opt/easydata/easyscheduler/runtime/log/launcher-<дата>.log" и "/opt/easydata/easyscheduler/runtime/log/runtime-<дата>.log".


Настройка файла параметров EasyRuntime

При установке EasyRuntime устанавливается файл параметров его запуска по пути "<Путь установки>/EasyScheduler/runtime/easyruntime.vmoptions". В этом файле можно добавить или изменить следующие параметры:
Название | Описание
-Djava.rmi.server.hostname | TCP/IP V4 сетевой адрес сервера, по которому EasyRuntime будет работать с внешним управляющим WebCenter сервером.
-Xmx<Количество> | Максимальный размер памяти, который EasyRuntime может забирать у ОС. Количество задается как число с суффиксом M (мегабайты) или G (гигабайты). По умолчанию используется 256 мегабайт (256M).


Настройка файла конфигурации EasyRuntime

В параметрах рантайм сервера можно задать следующие значения:
Название | Описание
runtime.path.task-history-log | Путь к директорию для хранения логов истории задач. По умолчанию логи выполненных задач хранятся по пути установки в директории "runtime/storage/task_history_log". Рекомендуется изменить, если требуется хранить логи в другой директории.
runtime.path.packages | Путь к хранилищу пакетов задач. По умолчанию пакеты хранятся по пути установки в директории "runtime/storage/package". Рекомендуется изменить, если требуется вынести хранение архивов пакетов в другую директорию.
runtime.path.temp | Путь к временной директории хранения промежуточных файлов. По умолчанию используется директория с переменной среды "temp" операционной системы.
launcher.rmi.port | Порт связи EasyRuntime с WebCenter. По умолчанию 9100. Можно изменить, если этот порт на сервере занят другим приложением. При изменении нужно изменить порт в интерфейсе описания рантайм сервера EasyScheduler.
runtime.rmi.runtime-management-port | Пор выполнения команд EasyRuntime, передаваемых с WebCenter. По умолчанию 9100. Можно изменить, если этот порт на сервере занят другим приложением. При изменении нужно изменить порт в интерфейсе описания рантайм сервера EasyScheduler в поле "Параметры рантайм сервера", указав там: runtime.rmi.runtime-management-port=<порт>
runtime.disk-min-space | Не запускать задачи на сервере EasyRuntime, если количество доступного места менее заданного количества в байтах. По умолчанию опция выключена.